close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

plugin delete not working

Thread began 10/17/2016 3:34 pm by Jamie | Last modified 10/18/2016 1:09 pm by Ray Borduin | 505 views | 6 replies |

Jamie

plugin delete not working

have the attached customer_update page which has got a plugin using message_results

if I delete an item in the message_results plugin,

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ORDER BY MessageDate DESC LIMIT 0, 50' at line 1



I am pretty sure its to do with this within the select statement

WHERE MessageUserID = {$_SESSION['UserID']}

but I need that to display the messages that are associated with that user...

What am I doing wrong please?

Cheers

Jamie

Sign in to reply to this post

Ray BorduinWebAssist

"SELECT * FROM messages WHERE MessageUserID = " . $_SESSION['UserID'] . " ORDER BY MessageDate DESC";

Sign in to reply to this post

Jamie

thanks but still getting
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ORDER BY MessageDate DESC LIMIT 0, 50' at line 1

Sign in to reply to this post

Ray BorduinWebAssist

Are you sure the session variable is set?

Try writing your SQL statement to the page before the line with mysql_query( (afterline 65) add:

die($query_limit_WADAmessages);

See if you can spot the problem with your SQL statement.

Sign in to reply to this post

Jamie

ok, its returning SELECT * FROM messages WHERE MessageUserID = ORDER BY MessageDate DESC LIMIT 0, 50
so clearly UserID is not being set on the plugin although whne I was echoing the session to make sure it was showing the right user it worked ok

am assuming then that it has to do with the delete function but not sure what I need to do to get it set...

Sign in to reply to this post

Ray BorduinWebAssist

Is the session variable being reset? I see your set session code is:

if ("" == "") {
$_SESSION["UserID"] = "".($_GET['UserID']) ."";
}

That means that if you visit that page without the url parameter it will be reset to blank.

Perhaps it should be:
if (isset(($_GET['UserID']))) {
$_SESSION["UserID"] = "".($_GET['UserID']) ."";
}

Sign in to reply to this post

Jamie

thats done it. Thanks Ray

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...