close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

File permissions for Power CMS Builder on localhost

Thread began 10/09/2016 6:34 pm by mjon67244103 | Last modified 10/20/2016 9:31 pm by Ray Borduin | 66 views | 6 replies |

mjon67244103

File permissions for Power CMS Builder on localhost

I am using PowerCMS Builder on Mac OS 10.10.5, using Dreamweaver CC 2015.2. As a testing server I am using MAMP Pro 4.0.5, with Apache 2.2.31 and MySQL 5.6.28.

I've been using the video tutorial at https://www.youtube.com/watch?v=tGUP3-BnVfU as a guide. I'm trying to add a CMS to an existing site.

I create a database using phpMyAdmin, and can define it in PowerCMS Builder, but the Server Diagnostic Check always fails with File Permissions.

I have checked permissions for the directory that contains the site folder on the testing server, using phpMyAdmin. I have checked permissions using the File Access Permissions tab in DW. I have checked permissions using Finder Get Info.

I have checked numerous forum articles regarding this problem but can't get past it.

Thanks in advance for your assistance!

Sign in to reply to this post

Ray BorduinWebAssist

Can I see a screen shot of the error as well as the folder get info window? That should be all that you need to adjust.

Sign in to reply to this post

mjon67244103

Screen shots

Attached are screen shots of file info and error message. Thank you!

Sign in to reply to this post

Ray BorduinWebAssist

In your getInfo "everyone" has "read only" access... change that to "Read & Write" and see if that fixes the problem.

Sign in to reply to this post

mjon67244103

No go

Thanks for your response, Ray. I changed the "everyone" access to Read & Write - same result: File Permissions error

Sign in to reply to this post

Ray BorduinWebAssist

Did you make the change for the root folder for the site as well as the /Connections folder? Are you putting the files right in the root or a sub-directory? Maybe try a sub-directory... you may have better control of the permissions outside of the root.

Sign in to reply to this post

mjon67244103

Yes, changing the permissions using File Info specifically for the Connections folder did the trick. Thanks for your help, Ray!

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...