close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Warning: date(): it is not safe.........

Thread began 5/06/2016 7:15 pm by gzirfas374932 | Last modified 5/09/2016 1:40 am by Ray Borduin | 63 views | 2 replies |

gzirfas374932

Warning: date(): it is not safe.........

I had to move one of my sites. Everything went smoothly except for this error:

Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /home/administratorhc/public_html/CMS/images/installed.png on line 2

site: heritagecircle.org

heritagecircle.org/index-hold.php

I can, of course, turn off error reporting for this but would rather find and nuke the error, can you assist?

also getting this error in heritagecircle.org/CMS:
Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/administratorhc/public_html/CMS/images/installed.png:2) in /home/administratorhc/public_html/CMS/WA_SecurityAssist/Helper_PHP.php on line 5

Warning: Cannot modify header information - headers already sent by (output started at /home/administratorhc/public_html/CMS/images/installed.png:2) in /home/administratorhc/public_html/CMS/admin_cms/users_login.php on line 45

Warning: Cannot modify header information - headers already sent by (output started at /home/administratorhc/public_html/CMS/images/installed.png:2) in /home/administratorhc/public_html/CMS/admin_cms/users_login.php on line 48

Sign in to reply to this post

Ray BorduinWebAssist

All of the other errors are as a result of the first.

The best solution is to set the default timezone in the php.ini file by setting the value for date.timezone. This can usually be done in your server's admin control panel.

Sign in to reply to this post

gzirfas374932

Corrected, thanks

i could not find it in the admin panel so I added
date.timezone = "US/Mountain"
manually to the php.ini file and EVERYTHING is groovy. All errors resolved.

Again, as always, thanks for your help -- YOU ARE A GENIUS!!!!

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...