close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

I'm getting a Syntax Error when I use the delete icon for a record on the results form I generated.

Thread began 2/17/2016 4:07 pm by anonymous | Last modified 2/18/2016 9:33 pm by Ray Borduin | 404 views | 11 replies |

anonymous

I'm getting a Syntax Error when I use the delete icon for a record on the results form I generated.

I've generated forms using the form generation wizard and after everything was generated, I added some extra sorting parameters for the results page. When I use the delete button I now get the following...You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '%test%) ORDER BY Lastname, Firstname, Company, Zip, Phone, Email ASC LIMIT 0, 2' at line 1

How can I correct this? I've included the forms I've created and I've also tested this with the original forms I generated and I got the same error.

Attached Files
SUBSCRIP_detail-5.php
SUBSCRIP_insert-5.php
SUBSCRIP_results-4.php
SUBSCRIP_search-13.php
Sign in to reply to this post

Ray BorduinWebAssist

after line 153 add this:

echo($query_WADASUBSCRIP);

It appears to have something to do with the search on the page, but I'll need to see the full query to look into it further. I could need FTP access for this one to debug and edit files where necessary.

Sign in to reply to this post

anonymous

Still the same result

Hello Ray... I tried inserting that line of code after line 153 on my results page but the same thing happened. I got the same error message and the record was not deleted. I've given you the log in to my page in the private section below.

Also... there was a search field I initially left out of my search page when I created it that I would like to add. The field is Addrprob. I've tried copying the code from another similar record and then adding in the right field... and I have the field included on the results form... but when I click "Search" the search form is not sending the field parameter to the results form. Could you please let me know what I've overlooked? This field is actually a "T" or "F" character that tells me whether the subscriber is online only or print so it's something I really need to include.

I'll provide me FTP log in in the private section of this message

Thanks in advance! Dan Lewis

Attached Files
SUBSCRIP_detail.php
SUBSCRIP_results.php
SUBSCRIP_search.php
SUBSCRIP_update.php
Sign in to reply to this post

Ray BorduinWebAssist

What are the exact steps to reproduce the problem. I went to that page, clicked the search button, then clicked delete for the first record and it deleted without errors.

I'll need to reproduce the problem before I can debug it.

Sign in to reply to this post

Daniel

Deleting record

I did work on it a bit last night. Maybe I succeeded and didn't realize it. I'll try it with a different web browser too. That sometimes works

Do you have any pointers on how to add the searching capability for my search page. I did generate a new set of pages last night and experimented by using the new search page with the old results page and the search worked fine. So therefore I know the problem is with my search page not sending the information to the results page.

The delete worked fine from my alternate browser so maybe the problem is with Firefox. I'm glad that problem is solved.

Sign in to reply to this post

Ray BorduinWebAssist

I'm afraid I don't really understand the issue.

Please explain what doesn't work on your page. What steps to reproduce, the result, and what the expected result would be and I can try to help.

Sign in to reply to this post

Daniel

Additional field on search page

Hello Ray... thanks for getting back to me. On my original search page at www.wheretheshowsare.com/subscribers-test I have a field to search called "Internet Only." The actual field in the database is "Addrprob" This is a field I have marked at "T" or "F" depending on whether the subscriber is an online only subscriber or not.

Originally when I generated the page I didn't include this as a search field... I added it yesterday. The problem is that when I enter a "T" or "F" into that field on the search page the submit button doesn't send that parameter to the results page. Obviously I missed some of the code necessary to make this happen. I did generate a new search page and I included that parameter and it works fine. But I would rather just add the search parameter to the existing page so I don't have to create the current search page from scratch.

I wondered it you could tell me what additional code I need to include so that the search will work.

Thank you! Dan Lewis

Sign in to reply to this post

Ray BorduinWebAssist

Can I get a current copy of the search and results page where you have tried?

Sign in to reply to this post

Daniel

Search & results pages

Here you go.

Attached Files
SUBSCRIP_results.php
SUBSCRIP_search.php
Sign in to reply to this post

Ray BorduinWebAssist

You have two fields in your form named Addrprob... you need to remove one or the other from the search page.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...