close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

SECURITY ASSIST LOGIN

Thread began 10/28/2014 9:53 pm by sebastian | Last modified 11/03/2014 3:52 pm by sebastian | 915 views | 12 replies |

sebastian

SECURITY ASSIST LOGIN

Hello i am having trouble with the security assist 2 feature. I am testing this site locally on my computer using local host and phpMyadmin. For some reason when i use security assist 2 to create my registration system, i cannot login. When i test the registration page it did update the user in the database, but when i test the login page it just goes blank after i submit the user email and password. I did use the User Authenticate to redirect it but it just shows up as a blank white page, or sometimes it says it cannot display the page because of a php error. Is this because i am testing the site locally? Help would be greatly appreciated!

Sign in to reply to this post

Jason ByrnesWebAssist

a blank page means that a php error is occurring but error reporting is turned off.

to turn error reporting on, add the following code at line 1:

<?php
error_reporting(E_ALL);
ini_set('display_errors','on');
?>



once we know what the error is, we will be able to troubleshoot the cause.

Sign in to reply to this post

sebastian

i added the code to document and when i tested in browser i got this:

Deprecated: mysql_pconnect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /Users/George/Desktop/put stuff/Connections/test.php on line 11

After i clicked login i got the same blank white page with the same error on it :
Deprecated: mysql_pconnect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /Users/George/Desktop/put stuff/Connections/test.php on line 11

any ideas??

Sign in to reply to this post

Jason ByrnesWebAssist

in the php.ini file for your testing server, you will need to disable the deprecated error level.

to find where the php.ini file is located, create a new file yin your site named phptest.php and add the following code:

<?php phpinfo(); ?>

then view that page in the browser, look for the Loaded Configuration File, this will give the path to the php.ini file, in that file, find the error_reporting setting, and set it to:

error_reporting = E_ALL & ~E_DEPRECATED


you will need to restart the server after making the change.

Sign in to reply to this post

sebastian

i did that and still it goes to the blank white page, not to my index.php.

although when i click login now, when i go to my database i can see a new entry from the username that just logged in with a date. so it appears to be sending it to the database i just don't know why it doesn't redirect me to my index.php like i wanted

does this mean its working? if my database has an entry with a date on ?

Sign in to reply to this post

Jason ByrnesWebAssist

send a copy of your page please.

A log in page should not insert to the database.

A login page looks up the entered information to check if it is in the database or not.

Sign in to reply to this post

sebastian

When i click login with my information, i get a "page cannot be displayed" error code after the progress bar. Right now the login.php is all default settings link to my user table in my database. There are hidden fields that only appear if the person is logged in, invalid username or password and i don't even see any of those, jus a page cannot be displayed error code.

Attached Files
login.php
Sign in to reply to this post

sebastian

See PM

Sign in to reply to this post

Jason ByrnesWebAssist

On the login page, the code for including other files is set to virtual:

for example:
<?php virtual('/Connections/test.php'); ?>

this should be require once instead:
<?php require_once('Connections/test.php'); ?>


This is caused by a setting in your site definition.

I nthe site definition, the setting for "Create Links relative to" is set to Site. this will cause DW to use the virtual function on include files. change that to Document so that DW will use the require_once function instead.

you will either need to change that setting in the site definition, then delete the security assist pages and recreate them, or go through each page and change the include file lines to use require once.

Sign in to reply to this post

sebastian

Thanks. works now. See pm

Thanks

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...