close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Upload Wizard not displaying field name

Thread began 10/09/2014 10:25 am by mouse426912 | Last modified 10/09/2014 3:33 pm by Jason Byrnes | 820 views | 7 replies |

mouse426912

Upload Wizard not displaying field name

Hi. I am trying to put an upload field into an insert page using the FileManipulation > Upload Wizard. I am following the instructions from http://www.webassist.com/tutorials/Add-file-fields-to-Data-Bridge-insert-update-pages.

After creating the field, there is no browse button next to the field, I am actually doing a copy/paste from another page to get the browse button to show, when I open the Upload Wizard, the dropdown field for the File Field does not work. I manually type it in. Then I did the binding. When testing, the file is uploaded to the correct directory but the name is not appearing in the database.

I am attaching the code. What am I missing please?

Thanks
Miki

Sign in to reply to this post

Jason ByrnesWebAssist

edit the form tag and set the encoding type to mutipart/form-upload

Sign in to reply to this post

mouse426912

I edited the form tog to this:
<form class="Basic_Default" id="Insert_Basic_Default" name="Insert_Basic_Default" method="post" action="<?php echo (htmlentities($_SERVER["PHP_SELF"], ENT_QUOTES)); ?>" enctype="multipart/form-upload">

But now the document does not upload to the server nor does the file name get into the database.

Thanks

Sign in to reply to this post

Jason ByrnesWebAssist

sorry, should be multipart/form-data;


enctype="multipart/form-data"

Sign in to reply to this post

mouse426912

LOL - I was wondering - I thought - Wow! that's a new one! So, that worked, thanks.

Next question - why did that not go in when the form was created?

Miki

Sign in to reply to this post

Jason ByrnesWebAssist

well, you say that when you added the field, it did not show the browse button, this can only happen if the field you added was not a file field.

you then pasted in the file field from another page, it wont automatically change the encoding type unless you use the DW Insert -> Form -> File Field menu point to add the file field.

if you manually add the file field, you need to manually edit the encoding type.

Sign in to reply to this post

mouse426912

Thank you - I hope I can remember this. It is working fine now. This is resolved and thanks for your timely replies.

Miki

Sign in to reply to this post

Jason ByrnesWebAssist

you're welcome.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...