close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Could a temp url be messing up KFM

Thread began 11/12/2013 7:13 am by gruant2000381341 | Last modified 11/12/2013 11:26 am by Jason Byrnes | 521 views | 1 replies |

gruant2000381341

Could a temp url be messing up KFM

I am having an issue with the KFM image management system.

I can upload images, and browse images.
I have verified that the images have been uploaded onto the server.

When I choose the image to be placed, I get a broken link in the editor and on the live page.
The source view for the image looks like it should be okay.
<img alt="" src="/home2/xxxxxx/public_html/my_content/files/place200.jpg" />
if I manually edit that to...
<img alt="" src="/my_content/files/place200.jpg" />
then the image shows correctly in the editor and the live page

Now I have to tell you that I am running under a temporary url, as we have not transferred the domain yet and have not changed the nameservers so I am visiting the test site via...
http://11.111.111.111/~xxxxxxx/testpage.php
Could that temporary url be the culprit?

I went through the KFM tables to see if there was an issue in there and noticed this
In the KFM session vars table... in the kfm_url field...
"http:\/\/11.111.111.111\/~xxxxxxxx\/my_content\/webassist\/kfm\/index.php?\/\/home2\/xxxxxxx\/public_html\/my_content\/webassist\/"
which holds that temp url

but then in the kfm_settings table...in the value field, I have....
/home2/xxxxxx/public_html/my_content/webassist/kfm

Would the temp url be causing all this?
When we transfer the domain, will I need to delete all these KFM tables, and delete the "files" folder so it will "re-install" with the proper domain and path to the images? Is there anything else I would need to do or delete to make it re-install?

Or, would simply changing this...
"http:\/\/11.111.111.111\/~xxxxxxxx\/my_content\/webassist\/kfm\/index.php?\/\/home2\/xxxxx\/public_html\/my_content\/webassist\/"
to
"http:\/\/www.mysite.com\/my_content\/webassist\/kfm\/index.php?\/\/home2\/xxxxx\/public_html\/my_content\/webassist\/"
in the session vars table fix it when we transfer the domain

Sign in to reply to this post

Jason ByrnesWebAssist

Yes, the temporary URL is causing the path to translate incorrectly.

once you have the correct URL, the image selection should generate the correct path.

you wont need to change or delete anything for this to work once the domain is transferred.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...