close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Web assist "insert new form"

Thread began 10/30/2013 4:04 pm by russb335115 | Last modified 11/05/2013 1:43 pm by Jason Byrnes | 1182 views | 7 replies |

russb335115

Web assist "insert new form"

I have a form on a page and when submitted I get this error:

Fatal error: require(): Failed opening required 'Block.php' (include_path='.:/usr/lib/php6') in /homepages/19/d403739231/htdocs/champPerformance/webassist/email/mailformatting_php.php on line 151

The form is being sent to an email address.

Sign in to reply to this post

Jason ByrnesWebAssist

this means that there are some files that have not been uploaded to the server.

make sure to upload the entire /webassist/email/ folder

Sign in to reply to this post

russb335115

okay I did that and know I get this message in Dreamweaver (see image upload)

Also the form is not being submitted.

Sign in to reply to this post

Jason ByrnesWebAssist

that notice means that there where form elements on the page that used spry validation originally, but they have since been removed and the spry validation is left behind.

you will need to delete the spry validation for the elements that no longer exist.

send a copy of the form and a link where i can see the problem to troubleshoot why it is not submitting.

Sign in to reply to this post

russb335115

How do I set the function to "on success go to the success page" on the form submit function?

Sign in to reply to this post

Jason ByrnesWebAssist

on success of what?

is the form a login form? successful login? then use the Security Assist authentication server behavior to process the form, and set the success redirect in the authenticate user behavior.

is the form sending an email? if so, edit the Universal Email server behavor to set the go to page after the email is sent.

Sign in to reply to this post

russb335115

Thanks, that info was very helpful.

My only other issue is that the email being sent isn't making it to my client's email. I have the CC set to my email and that's working so i know the form is being submitted. Can you help?

Sign in to reply to this post

Jason ByrnesWebAssist

if it is going to one address but not the other, than it is an issue on the SMTP Server.

you will need to contact the host to have them look into the SMTP Server error logs to determine why the email is not being relayed to the clients address.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...