close ad
Help us test the new Databridge BETA with MySQLi support
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Forgot password: none of the show if messages appear

Thread began 12/02/2012 5:23 pm by thehalpeen319342 | Last modified 12/19/2012 1:11 pm by thehalpeen319342 | 1103 views | 11 replies |

thehalpeen319342

Forgot password: none of the show if messages appear

Dear Jason, None of the 'show if' confirmation validation messages ('Invalid information, please check your entries and try again' or 'Your email address could not be found in our records. Please try again' etc) appear if I send an email address.

Attached is zipped file.

I also want to clear all password encrytion for testing purposes, but the following message pops-up when I try and change the encrytion to none on the bottom of the selection pane - see attached pdf.

Attached Files
email encrypted password.pdf
forgotpassword.zip
Sign in to reply to this post

Jason ByrnesWebAssist

Those errors use Security Assist Show If rules.

how are the Security Assist rules defined that control those errors?


here are updated copies of the 2 files from the shared/webassist/securityassist/xml folder that should correct the problem. If you need help finding the configuration folder, see the common installation issues page:
common_installation_issues.php

Make sure to also delete the .dat file after replacing the 2 attached files.

Attached Files
xml.zip
Sign in to reply to this post

thehalpeen319342

Okay, thanks, I'll give it a go.

Sign in to reply to this post

thehalpeen319342

Sorry Jason, I forgot to answer your question. I ran the Security Assist wizard, and just incorporated the login page and the forgotpassword page into my site. I didn't create the 'show if's' myself. I'll update the files and run the wizard again and I'll let you know how I get on.

Sign in to reply to this post

thehalpeen319342

Jason, I've just managed to get around to dealing with the forgotten password issue.

Background: When user register, the pasword has no encryption.

Problem 1
I've copied/replaced the old the xml file with the new xml file that you sent me. I delete the cache. However after doing that, the same issues still exists - no 'show if messages' appear when you enter the email address and press submit. The progress wheel appears for a moment, but there's no message informing you that an email has been sent.

Problem 2
In a senario where I change the last field 'Password Encryption' in the server behaviour called 'SecurityAssist Email Encrypted Password' from MD5 to none (see pdf called 'forgot Password pop_up' - then in this senario, the progress wheel fails to appear and no email is sent - any reason? What exactly is this process doing of setting that to MD5 or none?

Attached Files
forgot Password pop_up.pdf
Sign in to reply to this post

Jason ByrnesWebAssist

make sure you are using the new Data Bridge 1.1.0 update that was recently released.

Sign in to reply to this post

thehalpeen319342

Okay, I need to upgrade from 1.0.9.

Sign in to reply to this post

thehalpeen319342

I've upgraded to 1.1.0. But I am still having problems.

Background:
On registration the user enters a username and password - none of which are encrypted.

Problem:
The user forgets their password. They enter their email address and an email is sent - but only if the server behaviour called 'SecurityAssist Email Encrypted Password' is set to MD5 under the database tab. If it is set to none, I get the message - 'Email failed to send. Please confirm your email settings with your hosting provider.' So why is this. I've read the help details but they aren't making things any clearer.

Also, when and if the user resets their password, it enters an encrypted password. This must be something to do with the way 'SecurityAssist Email Encrypted Password Return' is setup. Here, 'username' and 'password' encryption are set to 'none' - see attached pdf.

Attached Files
forgot Password return pop_up.pdf
Sign in to reply to this post

Jason ByrnesWebAssist

are you running the wizard? or creating the forgot password page manually?

if you are not using password encryption, you should not be using the 'SecurityAssist Email Encrypted Password' behavior on your page.


if the password is not encrypted, use the Email Password behavior. the Email Password behavior is for use with un encrypted passwords.

Sign in to reply to this post

thehalpeen319342

Dear Jason, the login details and forgot password were prepared with the wizard. I've now set all the password details back to MD5 (which I'm told is not secure) and everything seems to be in order.

Question 1
When would you set or in what situation would you set the 'email to encryption' - its the last line on the SecurityAssist Email Encrypted Password Return server behaviour - see attached pdf.

Question 2
Can you sent a user his password, if it has been encrypted - can you un-encrypt it in an email, instead of having to reset? It may not be good practice, but just wondering?

Attached Files
Password Encryption Return.pdf
Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...