close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Server Validations not working

Thread began 8/21/2012 12:45 pm by john70964 | Last modified 8/24/2012 3:11 pm by john70964 | 974 views | 13 replies |

john70964

Server Validations not working

I am trying to apply Server Validations but not getting very far.

After applying Validations to two text boxes and then browsing and clicking Insert
with nothing entered in either text box, the results page just appears.

I have removed

<!-- InstanceBegin template="/Templates/general.dwt.php" codeOutsideHTMLIsLocked="false" -->
to allow the validation to be applied

I am attaching a short version in a zip. Hope you may see what is not working.
Many thanks
John

Attached Files
insert_boat1_test.zip
Sign in to reply to this post

Jason ByrnesWebAssist

the page you sent is named insert_boat1_test.php, but the action of the form is to post to the insert_boat1.php page:

<form action="insert_boat1.php" method="post" enctype="multipart/form-data" name="WADAInsertForm" id="WADAInsertForm">


change the action of the form to post to the insert_boat1_test.php page instead.

Sign in to reply to this post

john70964

Sorry Jason my mistake in copying over..

Sign in to reply to this post

john70964

Hello Jason
I think the Server Validation is working correctly.

When Insert is pressed the page does not change.

I cannot seem to get "Validation Show If" working.

I have text in red "Enter a Manufacturer", I highlight this, select Validation Show If but that does not appear in the drop down box . I have uploaded an image of this and another zip with the file.

Thank you

John

Attached Files
insert_boat1_test.zip
Sign in to reply to this post

Jason ByrnesWebAssist

in the validation show if, you select the Validation that will trigger the message to show.

In this case, select the second validation in the list that is validating the Manufacturer for element.

Sign in to reply to this post

john70964

Sorry Jason I dont quite understand.

I am trying to get a validation message show if either manufacturer or Model is not completed.

If I highlight Enter a Model text then I can get the Validation Show if working but I cannot get the Enter Manufacturer text also to connect to Show Validation If.

I am attaching an image which I hope shows the situation.

Thanks
John

Sign in to reply to this post

Jason ByrnesWebAssist

have you tried Deleting the Dreamweaver Cache file from the users configuration folder:
common_installation_issues.php

if you still get the error message, can you send a copy of the page please.

Sign in to reply to this post

john70964

Hello Jason
I deleted the configuration file.
I highlighted the words in red "Entera Manufacturer".
I applied the Show Validaion If and this seemed to work

I closed the Show Validaion If Wizard.
I Highlighted the text Enter a Model

I opened the Show Validaion If Wizard and tried to apply this but it comes up with the error as shown in the attched image.

I also attach a zipped file.
Thanks
John

Attached Files
insert_boat1_test.zip
Sign in to reply to this post

Jason ByrnesWebAssist

I have created a support ticket so we can look into this issue further.

To view and edit your support ticket, please log into your support history:
supporthistory.php

If anyone else is experiencing this same issue, please append to this thread.

Sign in to reply to this post

john70964

I have now managed to get the field validations working.

I had not appreciated that each error notification needed to have a seperate Validation Show If applied. With that understood the Validation Show If is working.

This is an insert form.
When the insert button is applied and any validated field is incorrect then the complete form clears all entried so a user would have to begin the process again.

Is there a method which will prevent the correctly filled boxes from being emptied/deleted?

I tried using the Properties Lightning bolt
as on url
showthread.php?t=25332&highlight=show+validation+clear+field

but this is a new insert so may not apply in this case.
Thank you

John

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...