close ad
Help us test the new Databridge BETA with MySQLi support
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

DA Search Wizard in Data Bridge not finding recordset

Thread began 8/20/2012 5:57 pm by sandy170299 | Last modified 8/21/2012 2:05 pm by Jason Byrnes | 337 views | 3 replies |

sandy170299

DA Search Wizard in Data Bridge not finding recordset

I have the following recordset, which joins 4 tables together. I need to display the data from all four of these tables, but when I try to apply the WebAssist >> Database >> DataAssist Search Wizard, I get an error message that says: Please insert a recordset to use Database Search. The recordset also does not show up in my bindings panel anymore once I started joining tables together. Help? Here is the recordset:

$colname_WADAemployeesxjobsxlaborcodes = "-1";
if (isset($_SESSION['companyID'])) {
$colname_WADAemployeesxjobsxlaborcodes = $_SESSION['companyID'];
}
mysql_select_db($database_timesheets, $timesheets);
$query_WADAemployeesxjobsxlaborcodes = sprintf("SELECT employeesxjobsxlaborcodes.ID, employees.lname, employees.fname, employeesxjobsxlaborcodes.dateWorked, employeesxjobsxlaborcodes.hoursWorked, jobs.jobNumber, laborcodes.laborCode, employees.payRate, employees.companyID
FROM ((employeesxjobsxlaborcodes INNER JOIN laborcodes ON employeesxjobsxlaborcodes.laborCodeID = laborcodes.laborCodeID) INNER JOIN jobs ON employeesxjobsxlaborcodes.jobID = jobs.jobID) INNER JOIN employees ON employeesxjobsxlaborcodes.employeeID = employees.employeeID WHERE employees.companyID = %s ORDER BY employees.lname, employees.fname, employeesxjobsxlaborcodes.dateWorked DESC", GetSQLValueString($colname_WADAemployeesxjobsxlaborcodes, "int"));

Sign in to reply to this post

Jason ByrnesWebAssist

I have created a support ticket so we can look into this issue further.

To view and edit your support ticket, please log into your support history:
supporthistory.php

If anyone else is experiencing this same issue, please append to this thread.

Sign in to reply to this post

sandy170299

Jason, I think I've solved it. I reordered the tables in the query and now it works. Go figure...

Sign in to reply to this post

Jason ByrnesWebAssist

ok, glad to hear it is working.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...