close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Update information not showing

Thread began 8/08/2012 8:52 am by mouse426912 | Last modified 8/09/2012 12:23 pm by Ian S | 379 views | 3 replies |

mouse426912

Update information not showing

I have set up admin pages to display staff members with the following fields:
Name(text), Photo(char 55), Story1(textarea), Story2 (textarea), listOrder (int 11)

I applied File manipulation to the Photo field so that photos can be uploaded. This is something I have done before with no problem.

When I insert information, the photo field populates, the listorder field sometimes reads the input and sometimes does not.

When I update, I lose the photo field information and the listorder field goes to 0.

I am getting this error on the Results page: Notice: Undefined variable: totalRows_WADAstaff in /var/www/vhosts/brasslanternnantucket.com/httpdocs/newadmin/staff_results.php on line 25

No errors are being reported on the Details, Update or Insert pages.

I have attached the 4 pages

Thanks

Attached Files
Archive.zip
Sign in to reply to this post

Ian S

Regarding the photo information the order of your code is wrong.

Your update code is running before your upload code runs so you will be updating an empty value into the database. If you have a piece of code that refers to a variable in other code, that other code needs to run first otherwise the variable does not have a value.

Also, as you have a redirect in your update behaviour, the upload code will never run because you are telling the page to redirect before it gets to it.

Try correcting that for starters and see how you go from there.

Cheers
Ian

Sign in to reply to this post

mouse426912

Thanks, this worked but not completely

Your instructions did, indeed, solve the photo update problem but not the listOrder field problem.

When I went into the code on the Insert and Update pages, for some reason the listOrder field was not listed in $WA_fieldNamesStr or $WA_fieldValuesStr. I hand coded it in and it works now. Not sure why the listOrder was not picked up in the page generation. It was listed in the DataAssist Wizard and showed on the Details Page.

Thanks for your help

Sign in to reply to this post

Ian S

Great stuff! Glad to hear all is now OK.

Cheers
Ian

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...