close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Checkout not working

Thread began 7/26/2012 6:17 pm by Eric Goodman | Last modified 7/27/2012 1:01 pm by Eric Goodman | 791 views | 4 replies |

Eric Goodman

Checkout not working

I have a site that was doctored up by you. I had it under my old host provider that couldn't issue independent IP addresses so I masked it with the domain. It made a few problems. I had you try and fix the checkout and now that I moved the site to new hosting, SSL, independent IP and all, when I hit checkout it is redirecting to the old SSL folder. Any way of fixing it. www.shopjewelsforacause.com

Client wanted me to have it working asap. Thanks a million....

Sign in to reply to this post

Jason ByrnesWebAssist

the ssl redirect happens in the webassist/plugins/shoppoiong_cart/checkout_form.php file, the following line sets where it goes to:

php:
$testRedirect = "https://".$_SERVER['SERVER_NAME'].$_SERVER['REQUEST_URI'];




it uses the $_SERVER['SERVER_NAME'] variable as the domain.

you could hard code the domain by changing that to:

php:
$testRedirect = "https://www.shopjewelsforacause.com/".$_SERVER['REQUEST_URI'];
Sign in to reply to this post

Eric Goodman

Checkout issue

I added the code provided in place and it directs correctly now. One glitch I caught when doing a few dry runs on the store: I add a few products to the cart and click checkout. It then comes up with an empty cart. I tried again and it seemed to function fine. I repeated it and it glitched again and then again it worked, so this is kind of resolved? Any ideas?

Thanks for your attention...

Sign in to reply to this post

Jason ByrnesWebAssist

i bet you are testing without the www in the URL.

what you are describing will happen if you leave of the www:

shopjewelsforacause.com/


when the redirect goes to;
www.shopjewelsforacause.com/

this is a different domain as far as the session cookie is concerned, so a new session is started.


you can use an htaccess rule for your site if it apache hosted to force all traffic to the www address:
force-www-htaccess.html

Sign in to reply to this post

Eric Goodman

Wow

Thanks a million. Extremely helpful...

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...