close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Paste from Word not doing anything

Thread began 5/01/2012 9:55 am by Sweens | Last modified 5/08/2012 12:05 pm by Sweens | 16295 views | 6 replies |

Sweens

Paste from Word not doing anything

Hi

I've had the following reported:

"When trying to use the 'Paste From Word' facility in the Editor, I always receive notification that 'it was not possible to clean up the pasted data due to an internal error'. Looking at the source code of the pasted data, the Word formatting isn't cleaned at all.

Doesn't matter which browser I'm using - up-to-date versions of Chrome, Safari, Opera, Firefox and (god forbid!) IE. Makes no difference using .doc's over .docx's either."

Any suggestions?

Cheers
Chris

Sign in to reply to this post

Jason ByrnesWebAssist

what version of HTML Editor are you using?

also can you provide a sample of the content being copied from word that is causing the issue so that I can try to reproduce it.

Sign in to reply to this post

Sweens

Thanks Jason.

Using the latest version. I wonder if it's related to using a Windows server?

Word file attached - simple text, but after it tells me it can't paste the data, it iS pasted - but the code looks like this:

<p>
<!--[if gte mso 9]><xml>
<w:WordDocument>
<w:View>Normal</w:View>
<w:Zoom>0</w:Zoom>
<w:TrackMoves/>
<w:TrackFormatting/>
<w:PunctuationKerning/>
<w:ValidateAgainstSchemas/>
<w:SaveIfXMLInvalid>false</w:SaveIfXMLInvalid>
<w:IgnoreMixedContent>false</w:IgnoreMixedContent>
<w:AlwaysShowPlaceholderText>false</w:AlwaysShowPlaceholderText>
<w:DoNotPromoteQF/>
<w:LidThemeOther>EN-GB</w:LidThemeOther>
<w:LidThemeAsian>X-NONE</w:LidThemeAsian>
<w:LidThemeComplexScript>X-NONE</w:LidThemeComplexScript>
<w:Compatibility>
<w:BreakWrappedTables/>
<w:SnapToGridInCell/>
<w:WrapTextWithPunct/>


loads of lines removed

</style>
<![endif]--></p>
<h1>
This is just a test</h1>
<p class="MsoListParagraphCxSpFirst" style="text-indent:-18.0pt;mso-list:l0 level1 lfo1">
<span style="font-family:Symbol;mso-fareast-font-family:Symbol;mso-bidi-font-family:
Symbol"><span style="mso-list:Ignore">·<span style="font:7.0pt &quot;Times New Roman&quot;">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span></span></span>Sdfdsfsdf</p>
<p class="MsoListParagraphCxSpLast" style="text-indent:-18.0pt;mso-list:l0 level1 lfo1">
<span style="font-family:Symbol;mso-fareast-font-family:Symbol;mso-bidi-font-family:
Symbol"><span style="mso-list:Ignore">·<span style="font:7.0pt &quot;Times New Roman&quot;">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span></span></span>Dsfsdfgdg</p>
<p class="MsoNormal">
Dgdgdfgdf bjhb<span style="mso-spacerun:yes">&nbsp; </span><span style="mso-spacerun:yes">&nbsp;</span>jmnhb mjb jhgjhbgjhg j <span style="mso-spacerun:yes">&nbsp;&nbsp;</span>jhjhgvbj hgjhgj h<span style="mso-spacerun:yes">&nbsp; </span>gjhg jhgj hjh mjnhbmknnkjk<span style="mso-spacerun:yes">&nbsp; </span>jkhgj hgjh gj<span style="mso-spacerun:yes">&nbsp; </span></p>

Typical MS crud for 4 lines of text!

Cheer

Chris

Attached Files
test.zip
Sign in to reply to this post

Jason ByrnesWebAssist

looks like it is the List that word is creating, If i remove the list from your document, it does not create the problem, but I can reproduce with the list in place.


what version of word are you using? i created a list in my own copy of Word for Mac v14.0.0 and did not have the problem.

Sign in to reply to this post

Sweens

Thanks Jason

I have removed the bulleted list and the paste function now works perfectly, with the code removed.

I'm using Word 2007 0 saved as a .doc not .docx

Sign in to reply to this post

Jason ByrnesWebAssist

from what i have been reading, it seams to be a known issue with CKEditor and lists from word.

I'm not sure, but it may be fixed in the more recent 3.6.2 CKEditor version.

the CKEditor installation instruction can be found here:
Installation

the section titled Upgrade has details on upgrading the CKEditor, these instruction are valid for upgrading the version in Power CMS Builder.

Sign in to reply to this post

Sweens

Thanks Jason; however, the whole point of me buying extensions is that I don't need to wade through different processes to get things to work properly!

I will await an update to html editor which should have any fixes applied (including i-Pad/i-Phone compatibility, hopefully).

Cheers
Chris

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...