close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues


Error message at forgotpassword.php

Thread began 2/26/2012 3:17 pm by joerg431091 | Last modified 2/27/2012 11:11 am by Jason Byrnes | 564 views | 1 replies |


Error message at forgotpassword.php


I did setup the forgotpassword.php page and it actually works in that it does send the e-mail out with the correct login information after submitting but it does not redirect to the login.php page and gives the following error message instead:

Warning: Missing argument 6 for WA_SecurityAssist_Definition(), called in /[url]/forgotpassword.php on line 24 and defined in/[url]/webassist/security_assist/mail_php.php on line 34

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /[url]/webassist/security_assist/mail_php.php:34) in /[url]/webassist/security_assist/mail_php.php on line 239

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /[url]/webassist/security_assist/mail_php.php:34) in /[url]/webassist/security_assist/mail_php.php on line 239

Warning: Cannot modify header information - headers already sent by (output started at /[url]/webassist/security_assist/mail_php.php:34) in/[url]/webassist/security_assist/helper_php.php on line 133
It seems like only a mistake in the line 34 of the mail_php site but I can not figure out what the problem is.

Can anyone help?

Thanks a lot and best regards,


Solved the Problem:

I found a previous post with a similar problem that was solved by Jason and applied my settings and it worked perfectly. Just in case someone else has a similar problem:

As mentioned by Jason in a previous post, I replaced the following line in forgotpassword.php:

$WA_MailObject = WA_SecurityAssist_Definition("localhost","25","","","");


$WA_MailObject = WA_SecurityAssist_Definition("","25","","","","utf-8");

where: is the URL of the individual host.

Thanks Jason

Sign in to reply to this post

Jason ByrnesWebAssist

glad to hear you found the solution.

I believe this is an issue in older version of security assist.

make sure you have the latest version available from the download center installed.

If you have a previous version, make sure to uninstall it from the extension manager before installing the newer one.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question





Ease of use


security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...