close ad
Help us test the new Databridge BETA with MySQLi support
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

No database selected

Thread began 2/17/2012 11:20 am by bill3786 | Last modified 2/21/2012 2:18 pm by Jason Byrnes | 613 views | 3 replies |

bill3786

No database selected

When I call up the site index page using the local testing server and login, most of the time I get a "No database selected" message on a blank screen. This does not happen every time, there are occasions when login works first time.

If I then call up the site again and do a logout and then login everything works fine. Also I've noticed that while in the site and moving around I'll occasionally get the "No database selected" message.

Is this a quirk of local testing or is there a problem somewhere?

Sign in to reply to this post

Jason ByrnesWebAssist

since it does not happen every time on the same page, it sounds like a problem in the install of the local PHP / MySQL server.

maybe a port conflict with another program trying to use the same port as the apache web server (default is 80) or the MySQL Server (default is 3306)

But it's impossible to tell.

Sign in to reply to this post

bill3786

The site is now on a live server under a subdomain for testing. Everything works OK, products are displayed correctly, the registartion page adds data to the database and sends emails, the contact page sends emails. Hosting is with 1&1 business package.

Unfortunately the login does not work at all, always showing a blank screen with "No database selected". I've attached the login page.

I tried deleting the database on the live server and reistalled a new one but still the same no login as before.

Getting the login working is the main priority but I did have a few problems transfering from the local testing to live server and not sure if these are related to the login problem.

1. Had to manually change the links in the menu.php to get the menus to work, is this a normal?

2. Changed $WA_remoteRoot = in template (thus site pages) to = "/." as detailed by 1&1 hosting info. Again is this correct and does it have to be done manually. Also should $WAlocalRoot be left unchanged?

Attached Files
login.zip
Sign in to reply to this post

Jason ByrnesWebAssist

I have created a support ticket so we can look into this issue further.

To view and edit your support ticket, please log into your support history:
supporthistory.php

If anyone else is experiencing this same issue, please append to this thread.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...