close ad
Help us test the new Databridge BETA with MySQLi support
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

issue with USPS

Thread began 2/09/2012 10:06 pm by bill434989 | Last modified 2/10/2012 2:53 pm by Jason Byrnes | 598 views | 5 replies |

bill434989

issue with USPS

Not sure what I am doing incorrectly to make the USPS "shipping rule" work.

have contacted and received reply from USPS for access to Production Server. Here is what the email said:
Dear Bill,

Thank you for your quick response and for providing the name of your third party software. I would like to congratulate you on moving to production for the U.S. Postal Service's Web Tools Application Program Interfaces (APIs).

Your profile has been updated to allow you access to the Production Server.

1. The Production Server URL is: production.shippingapis.com. For APIs calling the secure server, the URL is secure.shippingapis.com.
2. There is a line of code that refers to "shippingapitest.dll". You'll need to remove the word "test".

If you are using third party software and need assistance, please contact the vendor of the software. They should be able to assist you in obtaining live information using our APIs.

If you have any additional questions or concerns, please contact us again.

Thank you,

Arielle S
USPS Internet Customer Care Center
uspstechsupport@esecurecare.net
Customer (Bill BillOfice)
01/31/2012 08:40 PM
Please set me up for the live system as I will be using V4 requests that
don't work on the test server. thank you.

Username is 123456789 (not actual name or password)
Password is ABCDEFG


I opened up the shippping rule box in Power Store and attempted to set up the US Postal service as a provider. Applied the User 123456789 and even tried both servers. but it does not show up in shipping charges when customer checks out. I have fed ex working ok and and a custom working but no USPS. Wondering what i am not doing right and what is the password for?

Sign in to reply to this post

Jason ByrnesWebAssist

what did you enter for the other settings in the shipping rule:
Label?
Destination Country?
Base Rate?
Per Item Rate?
Delivery Type?

can you send a link to your store so I can investigate please.

Sign in to reply to this post

bill434989

More INformation

Have 3 shipping rules
Fed Ex - Working Fine
Standard Shipping - working fine
Post Office (which is USPS) not showing up

Shipping rules for Post office are as follows:
Label: post office
Destination: United States
Base Rate:0
Per-Item Rate:0
Provider: US Postal Service
Delivery Type: Currently set to Priority but have tried First-Class as well
Username: xxxxxxx
Server:currently set to production.shippingapis.com/
but have also tried secure.shippingapis.com

Sign in to reply to this post

Jason ByrnesWebAssist

can you send a link to your store so I can investigate please.

Sign in to reply to this post

bill434989

Sorry, www.jmanphoto.com

Sign in to reply to this post

Jason ByrnesWebAssist

I have created a support ticket so we can look into this issue further.

To view and edit your support ticket, please log into your support history:
supporthistory.php

If anyone else is experiencing this same issue, please append to this thread.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...