close ad
Help us test the new Databridge BETA with MySQLi support
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Email unique column not working

Thread began 1/12/2012 6:25 am by romeo370381 | Last modified 1/24/2012 3:40 pm by steelace396915 | 1509 views | 15 replies |

romeo370381

Email unique column not working

Need help,

I don't know if there is anything else that I need to modify in order to make sure that two users cannot register with the same email, I can see the error message in the files, but when the site is live and try to register with the same email, I get no error, the registration goes on with no problem.

thx

Sign in to reply to this post

Ian S

How are you validating / checking the email address that is entered?

Are you doing it based on the contents of a recordset, or using the WA Validation Toolkit?

Cheers
Ian

Sign in to reply to this post

Jason ByrnesWebAssist

please send a copy of the registration page in a zip archive so we can see what you have set up so far.

Sign in to reply to this post

romeo370381

Dear

I am using the automatic set, and let even security access create a database table directly while creating the security pages.

I am attaching also the index page, because, if a use is a certain page, and are forced to log gin, they are not sent to the previous URL, they are being sent to the log gin success page again.

thx

Attached Files
Archive.zip
Sign in to reply to this post

Ray BorduinWebAssist

It looks like you have run the wizard multiple times on these pages and haven't fully cleared them out in between. This is probably the cause of your issue. Please try deleting these pages and starting from scratch. If you still have issues then send a copy of the newly created pages and we can help debug it.

Sign in to reply to this post

romeo370381

I tried again, and still

I created a complete new testing site, and made the same steps, just once, and didn't do any modifications on the generated pages, but still I could register the same email several times, so I am attaching the complete folder to this email.

thx

Attached Files
admin.zip
Sign in to reply to this post

Rune Brynestad

Solution

It looks like some files are missing in the
configuration\shared\lWebAssist\ibrary folder

Ray was able to resolve the problem in a connect meeting by manually copying all the files from the
configuration\shared\lWebAssist\SecurityAssist\library folder to the
configuration\shared\lWebAssist\ibrary folder

once the files were copied to that location it appeared to start functioning properly.

Regards
Rune

Sign in to reply to this post

steelace396915

Im having the same problem! I can register several users with same email!?? I created a standard SA wizard set without modifications. Fresh DW install, fresh extensions install, all cleared before building the standard pages! Of course one could set email field in db as unique but the server validation behaviour should take care of that check!? I have tried manually editing the WA server validations in the registration page but nothing can be changed in that dialog!? If I delete a value and try to reapply it nothing changes! There is a validation typ "unique database value" which I tried to apply on the email field in addition to the "Email address" validation type but it does not work!?

/Martin J.

Sign in to reply to this post

Ian S

Martin,

When you say it doesn't work, do you mean you get a Javascript error or that the extension applies the validation but then doesn't work?

If you get the Javascript error there may be a file or two missing from your installation so you will need to get a support call logged with WA so that they can correct it for you.

I find that the Unique Database Value validation works very well after getting over the Javascript error hurdle.

Cheers
Ian

Sign in to reply to this post

steelace396915

Ian, what I meant was that it's possible to register with the same email over and over and just exchanging the values like name, address etc for the other fields in the registration form. I did not reflect over it until I saw this post and tested. Im still in a very initial stage building my site and when Ive tested I always used different email adresses. What do you alter to prevent user from register if trying to enter the same email adress like a previously registered user? I have tried changing values in the WA server validation behaviour but it's impossible to change anything in that dialogue after the wizard set has been built! I now almost have given up on SA wizard and started building the pages manually with Form Builder and applying the server behaviours afterwards. This works good but some elements created by SA wizard, like the forgotpassword page, is difficult to recreate manually. At least for a newbie like me.

/Martin J.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...