close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Contact Form - doesn't send or display thank you

Thread began 12/26/2011 2:10 pm by markf425338 | Last modified 8/21/2014 4:46 pm by Jason Byrnes | 3396 views | 10 replies |

markf425338

Contact Form - doesn't send or display thank you

I have successfully placed the Contact Form on 3 other sites including my own. For some reason I cannot get it to work correctly on a new site. I have it configured the same as on the other sites but on this new installation it won't display the Thank You confirmation page and it doesn't e-mail the info.

I'm not sure if this is pertinent, but the new site is here:

contactus.php

You may notice the address. this is a development address and will ultimately change to contactus.php. I'm not sure if that has any bearing on this problem I'm having.

Thanks in advance for any help you can provide with this.

Attached Files
WA_Globals.txt
contactus.txt
Sign in to reply to this post

Jason ByrnesWebAssist

you deleted the security question form element, but not the code to validate it.

delete the following line:

php:
$WAFV_Errors .= WAValidateLE(((isset($_POST["Security_question"]))?strtolower($_POST["Security_question"]):"") . "",((isset($_SESSION["random_answer"]))?strtolower($_SESSION["random_answer"]):"") . "",true,5);
Sign in to reply to this post

markf425338

Of course that was the user created problem. Thanks Jason!

Sign in to reply to this post

markf425338

Same Problem - Again

I am having trouble with the contact form again. It displays and can be filled out correctly. Once submitted it does not display the Thank You confirmation page and it doesn't e-mail the info.

Tried to start a new thread for this but couldn't seem to find where / how to do that.

Any help very much appreciated

Attached Files
WA_Globals.php
contactus.php
Sign in to reply to this post

Jason ByrnesWebAssist

try changing line 28:

if ((($_SERVER["REQUEST_METHOD"] == "POST") && (isset($_SERVER["HTTP_REFERER"]) && strpos(urldecode($_SERVER["HTTP_REFERER"]), urldecode($_SERVER["SERVER_NAME"].$_SERVER["PHP_SELF"])) > 0) && isset($_POST)))     {




to:

if ($_SERVER["REQUEST_METHOD"] == "POST")  {
Sign in to reply to this post

markf425338

Thank you Jason. I changed that line of code per your instructions but it still doesn't work. I can fill out the form and submit it but no Thank You message appears and I do not receive the form.

Sign in to reply to this post

Jason ByrnesWebAssist

I'll need to troubleshoot directly, see the private message section.

Sign in to reply to this post

markf425338

see th eprivate message

Sign in to reply to this post

Jason ByrnesWebAssist

i enabled error reporting by adding the following code at line 1:
<?php error_reporting(E_ALL); ini_set('display_errors','on'); ?>

This shows the following error

Warning: session_start(): open(/var/php_sessions/sess_d97e9feb4f90e0f6ec6b740fcda15f06, O_RDWR) failed: No such file or directory (2)


this is caused by a setting in the php.ini file, you will need to contact the host to have them correct the session.save_path

Sign in to reply to this post

markf425338

that's odd because I have exactly the same ContactForm103 at another site on the same host and it works fine.

Link to other site is in private message section

I contacted the hosting company and they made a change to the session.save_path fiile and now the form is working.

Thanks for your help!

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...