close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Form Creation

Thread began 12/03/2011 8:17 pm by fxs430566 | Last modified 12/20/2011 6:47 pm by fxs430566 | 1034 views | 7 replies |

fxs430566

Form Creation

Created contact form and getting this message when pressing F12 to view in IE 8...

Parse error: syntax error, unexpected '"', expecting T_STRING or T_VARIABLE or T_NUM_STRING in C:\xampp\htdocs\Milica\TMP1ytllvnneg.php on line 3

Please Help!

Sign in to reply to this post

Jason ByrnesWebAssist

please send a copy of your page so i can see the code at line3 that is causing the error.

Sign in to reply to this post

fxs430566

I attached the code in pdf.

Incidentally I get the error even if I create a new php and try to add a contact form from scratch.

Attached Files
contact.pdf
Sign in to reply to this post

Jason ByrnesWebAssist

I have created a support ticket so we can look into this issue further.

To view and edit your support ticket, please log into your support history:
supporthistory.php

If anyone else is experiencing this same issue, please append to this thread.

Sign in to reply to this post

fxs430566

Forms

Hi,

I really need help to resolve this problem because my development is stuck and I need to move on. I re-installed Forms Builder but it doesn't work. When I try to create a mailing form it creates it and displays in design view but when I F12 to view in IE8 I get;

Parse error: syntax error, unexpected '"', expecting T_STRING or T_VARIABLE or T_NUM_STRING in C:\xampp\htdocs\Milica\TMP4yz72wgjdf.php on line 3

Is it possible that the problem is caused by un-installing and re-installing Forms builder?

Reason I ask is that in my site directory there is a webassist folder which contains the following sub-folders;

Social
Progress_bar
html_editor
forms
form_validations
email
captcha

Do I need to delete them and let form builder re-create them?

Please advise I am at my wits end.

Thanks

Additional INFo

After I uninstall Forms Builder and start Dreamweaver I get the following Err msgs.

The following translators were not loaded due to errors:
The following javascript errors occurred;
Unablr to open script files C:\programfiles\adobe\adobe dreamweaver cs4\configuration\shared\Webassist\Documentencoding.js(Error 3)
I click ok and error repeats
I click ok and error repeats
I click ok and error repeats
Goes away on third ok.

When I exit Dreamweaver the error re-appears click ok three times and dreamweaver closes.

Attached Files
TMP8ozcrwgo73.zip
Sign in to reply to this post

fxs430566

Ok got it to work after several reinstalls. It seems the problem is that when first creating the form the SPECIFY THE ACTION PAGE is blank. Why is that?

In addition I am getting new error msg from Dreamweaver when creating form;

Error Generating Form:
TypeError:this.themeArray has no properties

Foloowed by;

While executing timer in WA_Site_Tools_Progress.htm, the following Java Script error occured:
At line 218 of the file "C:\Program Files\Adobe\Adobe Dreamweaver CS4\configuration\floater\WA_Progress\WA_ProcessingObject.js":
wa.sensitive.themeArray has no properties

Nevertheless the form is created and appears to be functioning.

Other problem is that somehow the server sided validation I add gets deleted.

Could someone please help?

Thanks

Sign in to reply to this post

fxs430566

Form Builder is not working. I deleted the page because I wanted to delete the form and start over. When I re-created the page and went to insert form it brings up the initial screen but does not populate the Specify Action Page unless I close DW several times and keep trying the insert form command until lo and behold it populates the Specify Action Page with the following: <?php echo(htmlentities($_SERVER["PHP_SELF"], ENT_QUOTES)); ?>

If I try to continue without this code populated and I manually enter the actual "mailing.php" page name in there I get the dreaded "Parse error: syntax error, unexpected '"', expecting T_STRING or T_VARIABLE or T_NUM_STRING in C:\xampp\htdocs\Milica\TMP4yz72wgjdf.php on line 3" error when I do an F12 to bring it up in IE8.

Lord have mercy.... HELP!!!

Sign in to reply to this post

fxs430566

Ok tech support got a hold of me earlier and suggested I remove Eric Otts Wireframing extension and re-install forms builder which I did with mixed results.

Here's what happens;
re-installed forms builder
I open DW and create a new php page
insert form, Specify Action Page field NOT populated

F12 in IE8
BOOM!
"Parse error: syntax error, unexpected '"', expecting T_STRING or T_VARIABLE or T_NUM_STRING in C:\xampp\htdocs\Milica\TMP4yz72wgjdf.php on line 5"

So now I did not save the previous php after inserting form and close it without saving so form code is discarded.

Close DW

Open DW

open previous php

insert form, Specify Action Page field populated

Works!

Why?

Basically when creating a new php page and immediatelly inserting form, it will not populate the Specify Action Page, when I pointed this out to the support person he said it did not matter that it would default to the open page. But it must matter otherwise it should work no?

I guess I can live with the work around if it holds but it'd be nice if we found out what's wrong. Does anyone else have the same or similar problem?

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...