close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

register_globals

Thread began 8/15/2011 7:49 pm by AndyG | Last modified 8/16/2011 2:14 pm by Jason Byrnes | 627 views | 3 replies |

AndyG

register_globals

guys
after having built a login and authentication system using SecurityAssist I now find that this will not work as my host does not allow register_globals to be ON! It would seem this is a fundamental requirement of this product.

Therefore, simply, what is the solution to enable SecurityAssist to work in this environment?

regards
Andy

Sign in to reply to this post

Jason ByrnesWebAssist

security assist does not rely on the register_globals setting being enabled.

it does rely on the $_GET, $_POST and $_SESSION supper globals though.

the register_globals = on setting only creates a friendly copy of a supper global that is set.

for example, if a session is set:
$_SESSION['mySession'] = "my var";

with regerster_globals = on, you could echo the session using either:
echo($_SESSION['mySession']);

or the friendly variable name $mySession:

echo($mySession);

turning registeer_globals off prevents the friendly variable $mySession from being created.

The register_globals setting is deprecated in php 5 and is not replied upon in Security assist


register_globals is not the cause of whatever issue you are encountering.

the first thing i would suspect is that the server will not properly store sessions, to test the servers session management, use the session test page from the following thread:
showpost.php?p=23826&postcount=2

Sign in to reply to this post

AndyG

release viroom

Jason
Thanks for the update.
I established late last night that the problem, as you state, has nothing to do with register_globals so in that respect I am happy as I know now that going forward SecurityAssist is not an issue with regards to this :)

The problem is, with the help of the script you supplied, a session management issue.

It appears that i do not have the appropriate permissions on my folder to enable writing of the session (to, I assume, the default session_save_path).

Is it therefore possible, within the folder, by use of a php.ini file or similar to set the session_save_path to this same working folder?
regards
Andy

Sign in to reply to this post

Jason ByrnesWebAssist

you will need to contact your host to have them correct the issues with the session.save_path.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...