close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Email received, but no content

Thread began 6/09/2011 9:54 am by Rune Brynestad | Last modified 6/15/2011 9:37 am by Jason Byrnes | 1626 views | 9 replies |

Rune Brynestad

Email received, but no content

I'm going to build my first newsletter. I'm setting up a web page that I want to use for design. The preview looks good in PowerMessenger (see attachment Preview.jpg).

I'm trying to send a preview to myself to see how it looks. When email is received, the mail body have no content (see attchment Email.jpg)

I'm attching the page that I use for design.

Any Ideas?

Thanks

Regards
Rune

Attached Files
newsletter.zip
Sign in to reply to this post

Jason ByrnesWebAssist

creating an email is not the same as creaating an HTML page, an email message cannot use styles from a style block:

<style type="text/css">
<!--
body {
margin-left: 0px;
margin-top: 0px;
margin-right: 0px;
margin-bottom: 0px;
background-image: url(images/bg_body.jpg);
background-repeat:repeat-x;
background-color: #4290BD;
}
.news {
font-family: Tahoma;
color: #C7DEEB;
font-size: 10px;
}
.text {
font-family: Tahoma;
font-size: 11px;
color: #606060;
}
.red {
color: #CC0000;
}
.tahoma_menu {
font-family: Tahoma;
font-weight: normal;
color: #F4A500;
}
.tahoma_menu_1 {
font-family: Tahoma;
font-size: 10px;
font-weight: bold;
}
.style3 {
font-family: Tahoma;
font-size: 10px;
color: #FFFFFF;
}
.style5 {font-family: Tahoma; font-weight: bold; color: #F4A500; }
-->
</style>




the styles must be specified inline using a style attribute.


also, links to images cannot be relative:
<img src="images/t2_bottom.jpg" width="535" height="18">


the email client needs to be given the full URL for the images:
<img src="http://mydomain.com/images/t2_bottom.jpg" width="535" height="18">

Sign in to reply to this post

Rune Brynestad

I see, should have thought of that.

Just one more small question. On the mail manager page there is a date displaying under "Created" (see attachment). I want to reformat the date to european date format instead of US date format. I know how to do this, but I'm not able to find out what page this date is comming from.

Thanks again.

Regards
Rune

Sign in to reply to this post

Jason ByrnesWebAssist

the returned date is set in the following function of the admin_pm/common/manager.js file:

function dateFormatter(cellvalue, options, rowObject){
// Split timestamp into [ Y, M, D, h, m, s ]
var t = cellvalue.split(/[- :]/);
// Apply each element to the Date function
var d = new Date(t[0], t[1]-1, t[2], t[3], t[4], t[5]);

return d.getFullYear() + '/' + (d.getMonth()+1) + '/' + d.getDate();
}




you can change the format by changing the last line:

return d.getFullYear() + '/' + (d.getMonth()+1) + '/' + d.getDate();




if you wanted yyyy/dd/month, change that to:

return d.getFullYear() + '/' + d.getDate() + '/' + (d.getMonth()+1);
Sign in to reply to this post

Rune Brynestad

Thanks, the date is showing the way I want now. Back to my first post:

I hav spesified the styles inline using the style attribute and also the full URL for the images.

However, it looks like the images spesified as backround images never shows up in the email. (See attachment)

I'm attaching the updated page that I use for design.

Thanks again for looking into this.

Regards
Rune

Attached Files
newsletter.zip
Sign in to reply to this post

Jason ByrnesWebAssist

many email clients do not support the background-image css property.

see the following for a listing of supported css properties for various email clients:
#p

Sign in to reply to this post

Rune Brynestad

Ok, thanks.

I have tested the spam report, but I get nothing sent to me. The confirmation message tells me that everything is ok. (See attchment).

The preview message works, but not the spam report. I'm using the 1.0.1 version of PowerMessenger.

Regards
Rune

Sign in to reply to this post

Jason ByrnesWebAssist

in the admin_pm/common/sendPreview.php file, change line 204:

php:
sendPreviewSpamCheckMessage($emailAddress, $fromName, "spamcheck@sitesell.net", $mailingSubject, $mailingContent);




to:

php:
sendPreviewSpamCheckMessage($emailAddress, $fromName, "check@isnotspam.com", $mailingSubject, $mailingContent);
Sign in to reply to this post

Rune Brynestad

Problem solved.

Thanks again for helping me.

Regards
Rune

Sign in to reply to this post

Jason ByrnesWebAssist

glad to hear it is working.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...