close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

eCart_DisplayMoney wrong

Thread began 5/20/2011 3:47 am by henk303241 | Last modified 6/30/2011 11:14 am by Jason Byrnes | 1212 views | 7 replies |

henk303241

eCart_DisplayMoney wrong

With the code: echo WA_eCart_DisplayMoney($eCart1, $eCart1->DisplayInfo("Price"));

I get a wrong value when the price is € 8,50:
Prijs per kaart: €8.5,00 | Totaal voor deze voorstelling: €17,00

With 2 numbers before the comma it show's all right:
Prijs per kaart: €15,00 | Totaal voor deze voorstelling: €30,00

What can I do to fix this?

Sign in to reply to this post

Jason ByrnesWebAssist

what does it show if you dont use the display money function?:
echo $eCart1->DisplayInfo("Price");


Send a screen shot showing the general tab of the eCart object so I can see your cart currency settings.

Sign in to reply to this post

henk303241

Hi Jason, then is shows 8.5
The screenshot is attached.
I have a problem with the shipping amount also. It displays as 2, but has to be 2,50.
(I posted it this mornig in a post with a simular problem)

Update: in the database, the shipping IS added as 2.50.

Sign in to reply to this post

Jason ByrnesWebAssist

please send a copy of the WA_eCart/eCart1_PHP.php file and a copy of the page that is displaying the price incorrectly so I can try to reproduce the issue.

Sign in to reply to this post

henk303241

Here are the files

Attached Files
Archive.zip
Sign in to reply to this post

Jason ByrnesWebAssist

I am not able to reproduce the problem with the files you have provided, but looking into the code in the eCart1_PHP.php file, I can see that there is some custom coding you have added, did you also add any custom code to the WA_eCart_Definition_PHP.php file?

Sign in to reply to this post

henk303241

I can't remember that I did some custom coding...? Can you give me the line numbers as wel as a "clean" file? Then I can use that file and see if that changes something.
I've added a screenschot from the site so you can see the problem.

Sign in to reply to this post

Jason ByrnesWebAssist

I have created a support ticket so we can look into this issue further.

To view and edit your support ticket, please log into your support history:
supporthistory.php

If anyone else is experiencing this same issue, please append to this thread.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...