close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Wamp Server won't validate server validations

Thread began 3/03/2011 3:57 pm by michael419508 | Last modified 3/03/2011 6:25 pm by Jason Byrnes | 2366 views | 5 replies |

michael419508

Wamp Server won't validate server validations

Tried to find the answer in the forums but none to be found.
Simple two field form with submit button.
When I upload to live server the server validations work. I am using server validation and validation show if.

Sadly the validation text from the show if does not show...but there are know errors.This is on the wamp server

Any thoughts?

Googled to see if there was some wamp issue.

Dreamweaver CS5 and super suite latest version
Firefox, Chrome and IE same issue.

Cheers
Mike

Sign in to reply to this post

Jason ByrnesWebAssist

can you send a copy of your page?

also try using the session test page from this post to make sure sessions are working correctly:
showpost.php?p=23826&postcount=2

Sign in to reply to this post

michael419508

simple form test for validation

Hi Jason,
Thanks for the quick response.
The sessionTest.php page started with Null and after clicking the link said test.
I cleared my cache and did this a couple of times. I have to clear the cache to make this work.

I attached the simple form test page.

Attached Files
contactforms.zip
Sign in to reply to this post

Jason ByrnesWebAssist

try changing:

php:
if (($_SERVER["REQUEST_METHOD"] == "POST") && (isset($_SERVER["HTTP_REFERER"]) && strpos($_SERVER["HTTP_REFERER"], $_SERVER["SERVER_NAME"].$_SERVER["PHP_SELF"]) > 0) && isset($_POST))  {




to:

php:
if ($_SERVER["REQUEST_METHOD"] == "POST")  {
Sign in to reply to this post

michael419508

That did it!

Thanks Jason!
Can you tell me why it produced the extra code?

I did delete every thing and started from scratch several times and this is the code it gave.
I even used the pdf tutorial (Getting started with validation toolkit) couple of times to make sure I wasn't missing a step.

I did test this on the live server as well and they are both working now

Thanks in advance
Michael

Sign in to reply to this post

Jason ByrnesWebAssist

the code you had was the Currant page submit trigger

the code I had you change it to was the any form post trigger.


the current page submit trigger wont work if the $_SERVER["HTTP_REFERER"] variable is turned off on your server.

you can make the server validation behavior generate the shorter code by selecting the Any form post trigger.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...