close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

error in IE

Thread began 7/15/2010 10:18 am by i.edwards384429 | Last modified 3/28/2012 3:41 pm by Jason Byrnes | 2403 views | 16 replies |

i.edwards384429

error in IE

Hi

re the following page is a form created using CSS form builder and UE4:

appointments.php in fire fox is ok

appointments.php in safari is ok

appointments.php in IE gives the following error

Webpage error details



Message: 'Spry.Widget.ValidationTextField' is null or not an object
Line: 851
Char: 2
Code: 0
URI: SpryValidationTextField.js

Any ideas as to why running IE8 on Vista

thanks

Ian

Sign in to reply to this post

Jason ByrnesWebAssist

it looks like the SpryAssets/SpryValidationTextField.js file on your server has been modified from the original.

I created a form with a spry text field and compared the SpryAssets/SpryValidationTextField.js code on my computer the src="SpryAssets/SpryValidationTextField.js file that is on your server, thew last line on your copy is:
})(); // EndSpryComponent



This is missing from my copy, try deleting that last line from the SpryValidationTextField.js file.

Sign in to reply to this post

i.edwards384429

update

Hi Jason

sorry that did not work, DW tells me that there is synax error on line 2359 of the file and when I upload and try it it still get the yellow exclamation and this error

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 1.1.4322; .NET CLR 3.5.30729; Tablet PC 2.0; OfficeLiveConnector.1.5; OfficeLivePatch.1.3; .NET CLR 3.0.30729; .NET4.0C)
Timestamp: Thu, 15 Jul 2010 18:57:05 UTC


Message: Expected '}'
Line: 2359
Char: 1
Code: 0
URI: SpryValidationTextField.js


Message: Object expected
Line: 344
Char: 1
Code: 0
URI: appointments.php


N ot a good day really.

I'll start from scratch tomorrow unless you have any more ideas?

thanks

Ian

Sign in to reply to this post

Jason ByrnesWebAssist

I have created a support ticket so we can look into this issue further.

To view and edit your support ticket, please log into your support history:
login.php

Sign in to reply to this post

steelace396915

Exactly the same problem! Has this been resolved?

Hi

I got exactly the same Spry error in my forms created from SA! Any solution to this??
Ive been struggling with this for days and nobody seems to know what's wrong!?
Ray is now looking into my problem and when and if there is a solution I will share it with anybody having the same problem.


Regards,
Martin J.

Sign in to reply to this post

Ray BorduinWebAssist

Am I working on it in a back end ticket? What is the url or ticket number and I'll look into it now.

Sign in to reply to this post

saf01

Hi. Im having the same issue.

I used latest SA2 before I had purchased and installed CSS Form Builder 2. SA 2 was using Validation Toolkit for Spry code on form fields and it worked without a problem. Then I installed CSS Form Builder 2, now SA is using form builders Spry code on form fields and Im getting the errors in IE, but all other browsers work with a problem.

I compared the code between files generated without CSS form Builder installed and with CSS Form Builder installed.

The old files in the head section of the files refer to ValidationToolkit/..php files
But with CSS Form Builder refer to webassist/forms/..php

I changed my files to refer to ValidationToolkit and it seems to work.

It may help, but not entirely sure what could be the cause.

Please advise.

Sign in to reply to this post

Ray BorduinWebAssist

Did you upload the files in the webassist/forms/ directory? It should be the same files we just started placing them in a different location.

Sign in to reply to this post

saf01

Yes I did - the webassist/forms/ directory.

CSS Form Builder works on its own, in all browsers, but as sson as I start using SA2 and create a simple database for the form fields, i get those errors - actually - i tried again to run the SA2 wizard from scratch using pre built simple registration - and still getting them, but only in internet explorer.

Not sure whats happening.

Sign in to reply to this post

Ray BorduinWebAssist

Is there a url where I can see the issue? That might help me determine the cause and suggest a solution.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...