close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Upload works locally but not remotely

Thread began 6/22/2010 10:53 am by anstara245021 | Last modified 6/22/2010 3:08 pm by Jason Byrnes | 1117 views | 4 replies |

anstara245021

Upload works locally but not remotely

Hi,
I have a page that does multiple operations, inserts, updates and deletes records and uploads or updates images relative to the record. It works really god on my localhost
but I can't figure out why it does not when online. The page does not upload images even if the file name is written in the record and all related data are written also.

I already tried to change permissions on the folder that should store images and everything seems ok, but no luck till now.

Thanks.

Attached Files
artisti_edit.zip
Sign in to reply to this post

anstara245021

Please... I need help.

Sign in to reply to this post

Jason ByrnesWebAssist

where it works locally, but not on the remote server, the extensions is configured properly, but you are running into a server setting that is causing the issue.

the most likely culprit is the php memory limit setting.

try adding the following at line 1:

php:
<?php

ini_set
('emory_limit','256M'):
?>




if you are still having an issue, find the following line:

$WA_redirectURL = "artisti.php";

and change it to:

$WA_redirectURL = "";

to prevent the redirect. This code appears 3 times, change it in all 3 locations.

Then turn error reporting on using this code at line 1:

php:
<?php

error_reporting
(E_ALL);
ini_set('error_reporting','on');
?>



then from the bindings panel expand the Uploaded files Global Status binding group and add the Debug Info binding to the page.

post back the results.

Sign in to reply to this post

anstara245021

Hi Jason, thanks for helping.
It seems that it was really a memory limit issue. Now the page uploads/updates correctly the images.
I removed the redirect urls, but for my purpose I need them so I'll try to rewrite and see what happens.

It's not the first time I use file upload and it has never happened anything like this.
If this trouble should happen again, how can I check if the problem is memory limit ?

Thanks for now.
Bye

Sign in to reply to this post

Jason ByrnesWebAssist

there's no sure fire way to know if it's a memory limit problem. If it happens again, try adding the ini set to increase the memory limit to see if it fixes the problem.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...