close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

eCart Shipping

Thread began 4/25/2010 12:56 am by david331670 | Last modified 4/27/2010 10:05 am by Jason Byrnes | 1076 views | 3 replies |

david331670

eCart Shipping

Me again.
I have my shipping set up to be a % of the item value plus a standard fee added to every item.

I have a few items that I do not want to charge shipping for.

I have tried a number of ways which dont work.
I keep trying a value in the cart related to "if there is a specific item in the cart" I want to make the shipping 0 See attached pic
How do I specify the itemIDs or groupIDs to make shipping flat rate $0.00.
I have two shipping triggers see attached pic.
Can this be done?
Thanks again
David

Sign in to reply to this post

Jason ByrnesWebAssist

to apply shipping to some items but no others, you need to create a new column in the eCart object that will be used to mark items that shipping applies to and items it does not apply to.


Crate a new column called freeShip.

In the add to cart button, set the freeShip column to 1 for items that should get a shipping charge and 0 for items that shipping should apply to.


then when creating the shipping rule, set the trigger to "number of items with a specific column value":
If the total number of items where "freeShip" has a value of "0" is ">" a value of "0"


For the calcualtion, use "Based on Items with a specific value "TotalPrice" where "freeShip" has a value of "0" "times" "0.10"


this will apply a 10 percent charge to all items where freeShip is set to 0.

Sign in to reply to this post

david331670

eCart No shipping

Thank you for your help so far.
I cannot make this work. I always get my normal charge.
I have 2 other shipping triggers & Local pickup, One is % of total purchase for shipping, one is charge per item based on number of items (for low cost items) and the new no shipping charge for Design work.
I have created a new column as per attachment, (called NoShip) The type is "number" (interger?? perhaps)
I have set up a new shipping rule with trigger as shown
I have set the cart button "NoShip to "0"
I still get a shipping charge.
I have tried different orders but no result.
What am I doing wrong
Thanks again
David

Sign in to reply to this post

Jason ByrnesWebAssist

you need to add the trigger and calculation i sent before to your other shipping rules



the shipping rule on the shipping tab are additive, if the other shipping rules don't have the correct trigger or calculation, they will still be applied.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...