close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Email issues and PEAR

Thread began 4/10/2010 2:43 pm by paul.urgero235355 | Last modified 4/23/2010 2:26 pm by Eric Mittman | 1283 views | 9 replies |

Paul

Email issues and PEAR

I'm having great difficulty configuring PS2 to send Verification Emails. While reading the posts in the forums, I read about using PEAR, which is installed on our server at: C:\PHP\PEAR

So in the User_Registration.php file, I configured Universal Email to use PEAR MAIL using SMTP, with the following settings:

Authenticate is checked
Email address and password are entered
Path to pear: C:\PHP\PEAR
SMTP server: 192.168.1.11
Port: 25

I've gone into the WAUE_users_Registration_1.php file, and changed line 15 to:
$WA_MailObject = WAUE_Definition("".($WAGLOBAL_Email_Server) ."","25","xxxxxxxx","xxxxxxxxx","True","","","","");

When I try and register an email address (whether one that is hosted on the same server or not), I get:
PHP Warning: require_once(192.168.1.11Mail.php) [function.require-once]: failed to open stream: No such file or directory in C:\Inetpub\wwwroot\hcprivate\AcalaMed\acalamedical.com\www\webassist\email\PEAR_Mail_using_SMTP_php.php on line 115 PHP Fatal error: require_once() [function.require]: Failed opening required '192.168.1.11Mail.php' (include_path='.;C:\php5\pear') in C:\Inetpub\wwwroot\hcprivate\AcalaMed\acalamedical.com\www\webassist\email\PEAR_Mail_using_SMTP_php.php on line 115

Line 115: require_once($mailObj->PearPath."Mail.php");

In my global settings, I've changed the mail server from "" to localhost, to 192.168.1.11.

I've tried changing the Mail.php to: C:\PHP\PEAR, no change.

One thing I can't understand, is the phpinfo test page shows: include_path .;C:\php5\pear but that path doesn't exist on the server, or in the php.ini file.

I am completely at a loss, and would appreciate any help, or for support to open up an immediate ticket.

Thanks,
Paul

Sign in to reply to this post

Eric Mittman

It looks like the paths are just not working out correctly. The first thing you should do is check what value the Pear Path is set to just before the line that gives you an error. It seems that the path is not getting to this area the same as you are entering it.

To check on this put in this code just before the error line 15:

php:
die("the pear path value is: " . $mailObj->PearPath);



This should stop execution and print out the message with the value for you. Let us know what it comes back with, also, post back with a copy of your page that has the UE on it and your UE folder from the site, I might help to have this code around as well.

Sign in to reply to this post

Paul

Hi Eric,

The answer came back as: 192.168.1.11

Thanks for your help.

Paul

Attached Files
WA_Universal_Email.zip
users_Registration.zip
Sign in to reply to this post

Eric Mittman

I have done some searching into this issue and I think I might have found out the problem. It looks like the first parameter you are passing into the WAUE_Definition is not correct. The first parameter in this function call should be the path to the PEAR object, instead you are passing it the server value.

It should look something like this:

WAUE_Definition("C:\\php\\PEAR\\","".($WAGLOBAL_Email_Server) ."","25","xxxxxxxx","xxxxxxxxx","True","","","","" );

Please update this and test it out, let us know if it does not resolve the problem. You will need to remove the debug code that you added to the file.

Sign in to reply to this post

Paul

Hi Eric,

No luck:

PHP Warning: require_once() [function.require-once]: open_basedir restriction in effect. File(C:\php\PEAR\Mail.php) is not within the allowed path(s): (C:\Inetpub\wwwroot\hcprivate\AcalaMed\acalamedical.com) in C:\Inetpub\wwwroot\hcprivate\AcalaMed\acalamedical.com\www\webassist\email\PEAR_Mail_using_SMTP_php.php on line 115 PHP Warning: require_once(C:\php\PEAR\Mail.php) [function.require-once]: failed to open stream: Operation not permitted in C:\Inetpub\wwwroot\hcprivate\AcalaMed\acalamedical.com\www\webassist\email\PEAR_Mail_using_SMTP_php.php on line 115 PHP Fatal error: require_once() [function.require]: Failed opening required 'C:\php\PEAR\Mail.php' (include_path='.;C:\PHP\pear') in C:\Inetpub\wwwroot\hcprivate\AcalaMed\acalamedical.com\www\webassist\email\PEAR_Mail_using_SMTP_php.php on line 115

Here's line 115: require_once($mailObj->PearPath."Mail.php");


Thoughts?
Appreciate the help!

Paul

Sign in to reply to this post

Eric Mittman

It looks like you have made the update correctly. The errors here are telling you that the open base dir directive is in effect. When this is set you can only include files that are within the specified path. In order to use include files you will either need to move all included files into the directory specified and update the paths or turn this restriction off. It would be much easier to turn this off. Depending on how it is set either directly in the ini or with safe mode being on you may need to contact your host to alter this setting.

Sign in to reply to this post

Paul

Eric,

I'm getting the same results. Whether open base dir is enabled or not, with the full path or not. Can someone open a ticket and contact me quickly? I'm running out of time.

I have full access to the server.

Thanks
Paul

Sign in to reply to this post

Eric Mittman

I opened a ticket for you on this. Please respond to the ticket in your support history, I have request the full current error message you are getting after you have turned the open base dir off.

Sign in to reply to this post

Paul

This posting is a continuation of another. Sorry for double-posting, but the other one was to get some view points.

But, as I mentioned to Eric in my support ticket, this issue has been fixed. And I am also not afraid to admit when user error rears its ugly head.

One of the test sites that I've created on my server is successfully sending verification emails. All these files are in their raw, unedited stage (except for the database and Connections files obviously). So this told me that it works on my server.

Somewhere through all the customizations, I must have changed one of the files somehow, in the WA_Universal_Email folder. I replaced the folder, and the users_Registration.php file, with the original files from the zipped PS2 download...uploaded them to my server, and successfully received the emails.

So the moral of the story is, if all else fails, replace the edited files with their originals.

Thanks for your help, Eric.

Sign in to reply to this post

Eric Mittman

I'm very glad to hear that. Did you ever get that test email script to work?

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...