close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Not sure what's wrong...

Thread began 3/30/2010 6:25 pm by Jackie340426 | Last modified 4/01/2010 10:46 am by Jackie340426 | 703 views | 5 replies |

Jackie340426

Not sure what's wrong...

Hi I am trying to install my CMS, second time doing this different web site.
I am using version 102 this time.

I am getting this error on my admin index.php page. Your help is most appreciated.
Thanks!


Warning: mysql_pconnect() [function.mysql-pconnect]: Lost connection to MySQL server at 'reading initial communication packet', system error: 111 in /hermes/web04/b178/as.kimmycomb/public_html/CMS/Connections/localhost.php on line 9

Fatal error: Lost connection to MySQL server at 'reading initial communication packet', system error: 111 in /hermes/web04/b178/as.kimmycomb/public_html/CMS/Connections/localhost.php on line 9

Sign in to reply to this post

Jackie340426

Error Message

Error is above

Sign in to reply to this post

neilo

Hiya Jackie,

While you're waiting for proper support, can you check that the info you have in your 'Connections/localhost.php' file is all correct:

<?php
# FileName="Connection_php_mysql.htm"
# Type="MYSQL"
# HTTP="true"
$hostname_localhost = "localhost"; /* This is probably correct. */
$database_localhost = "databasename"; /* Edit this */
$username_localhost = "databaseusername"; /* Edit this */
$password_localhost = "databaseuserpassword"; /* Edit this */
$localhost = mysql_pconnect($hostname_localhost, $username_localhost, $password_localhost) or trigger_error(mysql_error(),E_USER_ERROR);
?>
Sign in to reply to this post

Larry

If you are developing on your testing server, (home server), then you should just need to restart your server.

Larry

Sign in to reply to this post

admin140217

Jackie,

I just had this issue that took me a little bit of time to figure out.

In the $hostname_localhost of the localhost.php page if you're developing on your local machine, "localhost"; should work. If you are on the actual server and getting this error the path needs to change to the database server address, see my $hostname_localhost information below for reference:

$hostname_localhost = "daddyshomecms.db.#######.hostedresource.com"; $database_localhost = "daddyshomecms";

I'm using this on Godaddy hosting and is working well. PHPmyAdmin if available will give you the database server name.

Hope this helps

Sign in to reply to this post

Jackie340426

Thank you!

It worked thanks so much!

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...