close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Content not showing on website

Thread began 3/15/2010 8:56 am by info296210 | Last modified 3/17/2010 7:58 pm by Jimmy Wu | 1094 views | 7 replies |

info296210

Content not showing on website

Hi
I've loaded the CMS. Gone through to insert new content and added the developers code. Howeveer when I look at the development site I'm useing on the internet I get the following message.

Fatal error: Call to undefined function: wa_getcmscontent() in /homepages/19/d315727924/htdocs/WebsiteDNA/dev/auguries/TMPac92szbqa2.php on line 902

The hedaer and menu are showing fine so I presume the conncetion with the dtatabase is fine. Have I configured the content connection wrongly?

Any help really appreciated. Thanks Greg

Sign in to reply to this post

Jimmy Wu

On the page that has the error, is there an include for the WA_CMS.php file located in the WA_CMS directory? Also make sure that the WA_CMS.php file is indeed uploaded to the WA_CMS directory. This is the file that defines the wa_getcmscontent function that is causing the error.

Sign in to reply to this post

info296210

Thanks Jimmy

The only code I added to the web page was the code from the Web Developer section when I added the content created in the CMS. This code was:

<?php
include('/homepages/19/d315727924/htdocs/WebsiteDNA/dev/auguries/cms/WA_CMS/addtosite.php');
echo WA_getCMSContent($database_localhost, $localhost, 'index.php' , 'center');
?>

There is no include for WA_CMS.php. What coding should I add to the page and where should I include it? Many thanks Greg

Sign in to reply to this post

Jimmy Wu

You would want to add this at or near the top of the page:
<?php require_once( "../WA_CMS/WA_CMS.php" ); ?>

Depending on where the file is located in respect to the WA_CMS directory, you may have to change the path though.

Sign in to reply to this post

info296210

Hi Jimmy

Appreciate your help. I put in the extra include as suggested but still get an error showing as below:

Fatal error</b>: main() [<a href='plugins/function.require'>function.require</a>]: Failed opening required '../WA_CMS/WA_CMS.php' (include_path='.:/usr/lib/php') in <b>/homepages/19/d315727924/htdocs/WebsiteDNA/dev/auguries/index.php</b> on line <b>14</b><br />

I've still got the background colour image through the style.css folder but now lost the image and menu bar. Any ideas on how I can resolve the issue? Can be seen at index.php

Many thanks

Greg

Sign in to reply to this post

neilo

Hiya info,

Try changing:

<?php require_once( "../WA_CMS/WA_CMS.php" ); ?>

to:

<?php require_once( "cms/WA_CMS/WA_CMS.php" ); ?>

Sign in to reply to this post

info296210

All sorted. Great Forum

Many thanks neilo - really appreciate the help.

Greg

Sign in to reply to this post

Jimmy Wu

Great to hear it, if you run into any additional issues, feel free to open a new thread.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...