close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

email verification

Thread began 2/26/2010 6:27 am by i.edwards384429 | Last modified 2/26/2010 6:50 pm by Eric Mittman | 814 views | 8 replies |

i.edwards384429

email verification

Hi

Has anyone noticed that when the verification email is received it is not a link and required cutting and pasting?

More importantly has anyone worked out how to make the verification link clickable?

thanks

Ian

Sign in to reply to this post

John LangerBeta Tester

I've just had this issue with a client of mine. It wasn't to do with PowerStore but one of the other solution packs. It turned out that when I tested it the link was clickable. We concluded that it's a local thing. Perhaps your email client has links turned off for security reasons. I was also told that Hotmail has links turned off by default.

Hope that helps.

Sign in to reply to this post

i.edwards384429

Update

Hi John

interesting you've had it working because the code on the page does does not show any html for the link structure.

I modifed it from

<?php echo($WAGLOBAL_Root_URL); ?>users_Confirm.php?ID=<?php echo(mysql_insert_id()); ?>&code=<?php echo($_SESSION['randomConfirm']); ?>

to

<a href="<?php echo($WAGLOBAL_Root_URL); ?>users_Confirm.php?ID=<?php echo(mysql_insert_id()); ?>&code=<?php echo($_SESSION['randomConfirm']); ?>"><?php echo($WAGLOBAL_Root_URL); ?>users_Confirm.php?ID=<?php echo(mysql_insert_id()); ?>&code=<?php echo($_SESSION['randomConfirm']); ?></a>

but it still does not function,

I'll have to take another look.

Sign in to reply to this post

John LangerBeta Tester

Yes I thought that at first as well but the $WAGLOBAL_Root_URL places the URL of your site in front of all the rest. This is set in the Globals file and should follow the style of yourdomain.com/

It's this line

php:
//root url
$WAGLOBAL_Root_URL = ((isset($_SERVER['SERVER_PROTOCOL']) && strpos($_SERVER['SERVER_PROTOCOL'], 'HTTPS') !== false) ? 'https://' : 'http://') . $_SERVER['SERVER_NAME'] . $WAGLOBAL_localRoot;



I assume that it's filled in during set up. I only purchaced PowerStore last night and haven't actually used it yet but I assume that's it. Just check that line and make sure that it has your domain in there. If it has then i revert back to my original post and blame the end users email client / host.

Sign in to reply to this post

John LangerBeta Tester

Having had a good look at this today, it actually picks up the URL from the Server Variable "SERVER_NAME"

With that I think I'll hand over to the WA staff :)

Sign in to reply to this post

i.edwards384429

update

Hi John

yes I suspected that, however I've hit other issues that take precedence - like the paypal end seems to not work.

And it seems I can place an order without registering an address etc;-)

I'm hoping the WA team will help me sort it tonight - I sense a working weekend coming on

cheers

Ian

Sign in to reply to this post

Eric Mittman

The default functionality is to just insert the link like you mentioned. Mail clients will treat this differently, if links are not allowed making it into a standard html style link will not fix the problem. If links are allowed the url should be clickable, different browsers and mail clients will do this differently though. You could always add in some text to let the user know to cut and past the link if it is not clickable. This is a very common approach when sending email verification links.

When it comes to the problems you are having with the checkout please explain a little about the steps you are taking in your testing and the specific results you are getting including any errors.

Sign in to reply to this post

i.edwards384429

update

Hi Eric

I've put another post up about my paypal issues, no doubt it will be responded to due course.

As to the link being a hyper link is the link made in the php? because on the page there is no href. Also I've test it in outlook express, incredimail, windows mail and Outlook does not seem to be clickable in any of them

cheers

Ian

Sign in to reply to this post

Eric Mittman

In my testing in Outlook 2007, Thunderbird, and Gmail web based email the link is clickable by default.

If you have linking allowed in any of your mail clients it should not matter if the link is an href or just a URL, the client should recognize it and allow you to click on the link.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...