close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

Powerstore 3.01 Can't Create database.

Thread began 12/16/2010 2:57 pm by jcav26033 | Last modified 1/06/2011 2:28 am by jcav26033 | 1167 views | 4 replies


PS3.1 not loading database

I am experiencing a similar problem with installing PS3.1 as below.
Tells me to check my database connection but everything looks good.
I have also tried to export files from my testing server to the live database and bypass the install problem, but only half of the files are exported/imported.
Went back to the virgin install and it won't load the database. Tried the fix files, in desperation. or does PS3.1 already include the fix files? Either way they should just overwrite same?

Originally Said By: jcav26033
  Hi I am using a straight-out-of-the-zip install of Powerstore 3.01 in a subdirectory off of / called "store." I have not tampered with files in any way.

The server checks out completely (step 1). I enter localhost, databasename, root, my password. It goes to step 3.
When I get to step 3, the install script is unable to store the Admin credentials in the database...and no database has been created (when I connect through phpMyAdmin, there is no database created).

The "Connections" directory exists and the PowerStoreConnection.php file has the following:
# FileName="Connection_php_mysql.htm"
# Type="MYSQL"
# HTTP="true"
$hostname_PowerStoreConnection = "@@server@@";
$database_PowerStoreConnection = "@@database@@";
$username_PowerStoreConnection = "@@username@@";
$password_PowerStoreConnection = "@@password@@";
$PowerStoreConnection = mysql_pconnect($hostname_PowerStoreConnection, $username_PowerStoreConnection, $password_PowerStoreConnection) or trigger_error(mysql_error(),E_USER_ERROR);
Just to clarify, the variables are the actual credentials I need to log in to the database, not the variables listed here. But the tables are never built. I tried it with the database already present and that was no help. As root I have full access and all rights as do 2 other users I created. No one can login from the install script and the install script won't create the database.

I have been testing session variables and they are set. I have error-logging turned on and no php errors are being pitched.

Any ideas???  

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question





Ease of use


security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...