close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

image not displayed, only placeholder

Thread began 11/24/2010 9:41 am by info97301 | Last modified 11/30/2010 2:43 pm by info97301 | 987 views | 3 replies

info97301

Hi Dani

The two files that appear to contain the folder are config.php and configuation.php, (within different folders)

I changed them both from up/ to /up/ and found that when I uploaded an image, the path was being displayed as //up/image.jpg

So I looked at the two pages, and config.php contains the following code;

global $Config ;
$WA_EditorLocalRoot = '/';
$WA_EditorRemoteRoot = '/';
$WA_curURL = strtolower((isset($_SERVER["PHP_SELF"]))?$_SERVER["PHP_SELF"]:"");
$EditorAssumedRoot = $WA_EditorRemoteRoot;
if ((strpos($WA_curURL,strtolower($WA_EditorLocalRoot)) !== false && strpos($WA_curURL,strtolower($WA_EditorLocalRoot)) == 0) && (strlen($WA_EditorLocalRoot) >= strlen($WA_EditorRemoteRoot) || strpos($WA_curURL,strtolower($WA_EditorLocalRoot)) === 0)) {
$EditorAssumedRoot = $WA_EditorLocalRoot;
}


// SECURITY: You must explicitly enable this "connector". (Set it to "true").
// WARNING: don't just set "$Config['Enabled'] = true ;", you must be sure that only
// authenticated users can access this file or use some kind of session checking.
$Config['Enabled'] = (WA_Auth_RulePasses("Logged in to users"));

// Path to user files relative to the document root.
$Config['UserFilesPath'] = 'up/';
$Config['UserFilesPath'] = $EditorAssumedRoot.$Config['UserFilesPath'];
------------
I assumed that the line $WA_EditorRemoteRoot = '/'; was causing the //, so you will see from this I have removed the trailing '/' before up/

The other file, configuration.php doesn't have any reference to $WA_EditorRemoteRoot = '/'; so I have left it as /up/

Now, previously inserted images are displayed in the editor area and if I upload an image, everything is displayed properly.

However, if I go to 'browse server' and insert an image that has previously been uploaed, I get the //up path and the image is not displayed until I remove the /

Hope that's clearer than it sounds - I'm not a coder!

BTW - using advanced file management.

Cheers
Chris

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...