close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

When I apply a MySQLi Manage Relational Table behavior, it is somehow applying an old function

Thread began 4/17/2019 3:29 pm by TroyD | Last modified 4/30/2019 5:21 pm by TroyD | 189 views | 28 replies

TroyD

I reinstalled DB2 and it installed correctly so I was able to test the 3 methods of providing the array to the MRT. This is what I have experienced so far.

Both of the checkbox methods, Repeat Selection and Repeat Region worked correctly for me. “mrt_1” is added to the MRT query, as well as the hidden field “mrt_1[]” to the repeat of the checkboxes.
Preselect worked correctly as well as the update.
The only thing to mention here is that each time I open and apply the MRT wizard, it pops up a notice displaying the preselect echo that was added to the checkboxes (See attachment).
It doesn’t cause any problems, it just displays that block of code. I’m assuming it was for debugging or something. Just thought I would mention it.

As for the multi-select box method. Still not working for me. None of the selected options are retained or added when updating.

I removed the MRT and the multi-select and started from scratch with the same results.

The MRT behavior adds “mrt_1” to the MRT query, just like it did for the checkboxes, but nothing related to that is added to the multi-select.

It does add [] to the select name. And the getSelected() code is added, which does correctly preselect the currently applied options, however, it looses them when you click update.
The altered multi-select looks like this after the MRT is applied.

php:
<select name="u_DepartmentCategory[]" size="6" multiple="multiple" id="u_DepartmentCategory" required>

  <?php
while(!$rsDepartmentCategories->atEnd()) { //dyn select
?>
  <option value="<?php echo($rsDepartmentCategories->getColumnVal("DepartmentCategoryID")); ?><?php echo(in_array(($rsDepartmentCategories->getColumnVal("DepartmentCategoryID")),$RelationalQuery_1->getSelected())?"selected":""); ?> ><?php echo($rsDepartmentCategories->getColumnVal("DepartmentCategoryName")); ?></option>
  <?php
  $rsDepartmentCategories
->moveNext();
//dyn select
$rsDepartmentCategories->moveFirst();
?>
</select>



The rsobj.php version is 2.29 and the queryobj.php version is 2.19. Are those correct?

Let me know if I am overlooking something.

Thanks,
TroyD

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...