close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

MD5 with salt?

Thread began 4/05/2013 2:41 pm by john384495 | Last modified 4/29/2013 10:05 am by john384495 | 1120 views | 6 replies

john384495

Ok Jason...I learned a lot and hopefully you can direct me some more. I will only put part of the code since I think you know the easy parts already.

1. I was able to make an HTML file with an email and password field with submit button...blah blah blah :)
2. Made a PHP file started a session for the email and password.
3. Opened a database connection found the matching email.
4. Pulled the salt from the database ($salt = $row['password_salt'];)
5. Then took the session password and applied encryption ($password = md5(md5($password) . md5($salt));)
6. Then called the database again and compared $password with the database password (if ($respassword == $password) {)
7. Came back echo...congrats login.

Now even though it comes in login....nothing was set in their software so when I attempted to do location redirect it would only go to the log in page. So within the if statement of being login at attempted to use their service (which it worked).

8. Connect to their service.

define('TheirService', true);
define('TheirService_DS', DIRECTORY_SEPARATOR);

define('TheirService_DIR', dirname(__FILE__) . TheirService_DS . 'SomeFolder' . TheirService_DS);

define('TheirService_START_TIME', array_sum(explode(' ', microtime())));
require(TheirService_DIR . 'include' . TheirService_DS . 'ini.inc.php');

list($bSuccess, $aUser) = TheirService::getService('user.auth')->login($semail, $sPassword);

if ($bSuccess == true)
{
{header("Location: http://localhost/Domain/folder/index.php?do=/place/");
exit;

Now everything works...I can use their service to pull stuff from the database but I want to use my own login form...or I really mean to use your forms and software for an outside product so when they update their stuff it won't affect me unless they change the tables and field names...which they won't. I know you said I had to put the salt in wa_secuirtykey.php file but since MD5 does not use that in your software I am not too sure what you want me to learn or do as I added the login form and tried several things but nothing works. I am somewhat new at this and this last stuff took me at least a week to learn...although happy to learn it...very stressful figuring it myself. Like I said...I want to use webassist software to create forms, security and everything else webassist has I have purchased most of it but use their database to store info and retrieve info as well. If you could give me a helping hand I would really appreciate it....thank you in advance for your time :)

JohnJr

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...